GitHub Advisoryadvisory · RubyGems

GHSA-hww2-5g85-429m URI gem has ReDoS vulnerability

MEDIUM Published 2023-06-29 Modified 2025-11-04 Official page ↗
Aliases
CVE-2023-36617
Ecosystem
RubyGems
Packages
uri
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-1333
Reviewed
2023-07-14

Affected packages

• RubyGems uri: >= 0.10.1, < 0.10.3 → fixed in 0.10.3 • RubyGems uri: >= 0.12.0, < 0.12.2 → fixed in 0.12.2 • RubyGems uri: >= 0.11.0, < 0.11.2 → fixed in 0.11.2 • RubyGems uri: < 0.10.0.3 → fixed in 0.10.0.3

Description

A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with `rfc2396_parser.rb` and `rfc3986_parser.rb`. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version. The Ruby advisory recommends updating the uri gem to 0.12.2. In order to ensure compatibility with the bundled version in older Ruby series, you may update as follows instead: • For Ruby 3.0: Update to uri 0.10.3 • For Ruby 3.1 and 3.2: Update to uri 0.12.2. You can use gem update uri to update it. If you are using bundler, please add gem `uri`, `>= 0.12.2` (or other version mentioned above) to your Gemfile.

Related

Alias · CVE (1)

  • CVE-2023-36617 A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. vulnerability

Weakness · CWE (1)

  • CWE-1333 Inefficient Regular Expression Complexity weakness

References