GitHub Advisoryadvisory · Maven

GHSA-hx83-rpqf-m267 user/group information can be corrupted across storing in fsimage and reading back from fsimage

HIGH Published 2019-11-20 Modified 2021-08-18 Official page ↗
Aliases
CVE-2018-11768
Ecosystem
Maven
Packages
org.apache.hadoop:hadoop-main
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-119
Reviewed
2019-11-19

Affected packages

• Maven org.apache.hadoop:hadoop-main: >= 2.2.0, < 2.8.5 → fixed in 2.8.5 • Maven org.apache.hadoop:hadoop-main: >= 2.9.0, < 2.9.2 → fixed in 2.9.2 • Maven org.apache.hadoop:hadoop-main: >= 3.0.0, < 3.1.1 → fixed in 3.1.1

Description

In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be corrupted across storing in fsimage and reading back from fsimage.

Related

Alias · CVE (1)

  • CVE-2018-11768 In Apache Hadoop 3.1.0 to 3.1.1, 3.0.0-alpha1 to 3.0.3, 2.9.0 to 2.9.1, and 2.0.0-alpha to 2.8.4, the user/group information can be… vulnerability

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References