GitHub Advisoryadvisory · Packagist
GHSA-hxgg-4qww-85ph Moodle has reflected Cross-site Scripting risk in policy tool
MEDIUM
Official page ↗
- Aliases
- CVE-2025-3643
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-25
Affected packages
• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4
Description
A flaw was found in Moodle. The return URL in the policy tool required additional sanitizing to prevent a reflected Cross-site scripting (XSS) risk.
Related
Alias · CVE (1)
- CVE-2025-3643 A flaw was found in Moodle. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-3643 advisory
- https://github.com/moodle/moodle/commit/ff9bbd6d9e7d6267ce85e6c9afbeb19581f2a85f web
- https://access.redhat.com/security/cve/CVE-2025-3643 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2359742 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=467604 web