GitHub Advisoryadvisory · Maven

GHSA-hxgw-7539-pv7r Cloud Foundry denial of service vulnerability

HIGH Published 2022-05-13 Modified 2024-02-29 Official page ↗
Aliases
CVE-2017-4960
Ecosystem
Maven
Packages
org.cloudfoundry.identity:cloudfoundry-identity-server
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2024-02-29

Affected packages

• Maven org.cloudfoundry.identity:cloudfoundry-identity-server: >= 3.10.0, < 3.12.0 → fixed in 3.12.0 • Maven org.cloudfoundry.identity:cloudfoundry-identity-server: < 3.9.8 → fixed in 3.9.8

Description

An issue was discovered in Cloud Foundry release v247 through v252, UAA stand-alone release v3.9.0 through v3.11.0, and UAA Bosh Release v21 through v26. There is a potential to subject the UAA OAuth clients to a denial of service attack.

Related

Alias · CVE (1)

  • CVE-2017-4960 An issue was discovered in Cloud Foundry release v247 through v252, UAA stand-alone release v3.9.0 through v3.11.0, and UAA Bosh Release… vulnerability

References