GitHub Advisoryadvisory · npm
GHSA-hxmg-hm46-cf62 Remote code execution in mongo-express
CRITICAL
Official page ↗
- Aliases
- CVE-2020-24391
- Ecosystem
- npm
- Packages
- mongodb-query-parser
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2021-03-31
Affected packages
• npm mongodb-query-parser: < 2.0.0 → fixed in 2.0.0
Description
mongo-express before 1.0.0 offers support for certain advanced syntax but implements this in an unsafe way. NOTE: this may overlap CVE-2019-10769.
Related
Alias · CVE (1)
- CVE-2020-24391 mongo-express before 1.0.0 offers support for certain advanced syntax but implements this in an unsafe way. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness