GitHub Advisoryadvisory · Packagist

GHSA-hxqw-6qv7-cqfv Connect-CMS has Arbitrary Code Execution by an Authenticated User in its Code Study Plugin

HIGH Published 2026-03-23 Modified 2026-03-25 Official page ↗
Aliases
CVE-2026-32276
Ecosystem
Packagist
Packages
opensource-workshop/connect-cms
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2026-03-23

Affected packages

• Packagist opensource-workshop/connect-cms: < 1.41.1 → fixed in 1.41.1 • Packagist opensource-workshop/connect-cms: >= 2.0.0, < 2.41.1 → fixed in 2.41.1

Description

Security Advisory — Code Study Plugin Summary An authenticated user may be able to execute arbitrary code in the Code Study Plugin. Affected Versions • 1.x series: <= 1.41.0 • 2.x series: <= 2.41.0 Patched Versions • 1.41.1 • 2.41.1 Description In the Code Study Plugin, an authenticated user could trigger unintended code execution. If exploited, it may lead to code execution on the server or information disclosure. Users affected by this vulnerability should update to a fixed version. Solution Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later. Credits OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-32276 Connect-CMS is a content management system. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References