GitHub Advisoryadvisory · Packagist

GHSA-hxw5-9cc5-cmw5 LibreNMS stored Cross-site Scripting vulnerability in poller group name

LOW Published 2025-05-19 Modified 2025-05-19 Official page ↗
Aliases
CVE-2025-47931
Ecosystem
Packagist
Packages
librenms/librenms
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P
Weaknesses
CWE-79
Reviewed
2025-05-19

Affected packages

• Packagist librenms/librenms: < 25.5.0 → fixed in 25.5.0

Description

LibreNMS v25.4.0 suffers from Stored Cross-Site Scripting (XSS) Vulnerability in the 'group name' parameter of the 'http://localhost/poller/groups' form. This vulnerability allows attackers to inject malicious scripts into web pages viewed by other users. ---------------------------------POC----------------------------- Before Setting: Enable 'distributed_poller' in http://localhost/settings/poller/distributed 1. Attacker creates a new poller group and injects the payload in the 'group name' parameter ``` payload: alert('XSS') ``` 2. Victim navigates to the 'http://localhost/addhost' to add a new host 3. The payload is executed code sink: https://github.com/librenms/librenms/blob/25.4.0/includes/html/pages/addhost.inc.php#L284

Related

Alias · CVE (1)

  • CVE-2025-47931 LibreNMS is PHP/MySQL/SNMP based network monitoring software. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References