GitHub Advisoryadvisory · npm

GHSA-hxxf-q3w9-4xgw Malicious Package in eslint-scope

CRITICAL Published 2018-07-12 Modified 2021-09-14 Official page ↗
Ecosystem
npm
Packages
eslint-scope, eslint-config-eslint
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-506
Reviewed
2020-06-16

Affected packages

• npm eslint-scope: >= 3.7.2, < 3.7.3 → fixed in 3.7.3 • npm eslint-config-eslint: >= 5.0.2, < 6.0.0 → fixed in 6.0.0

Description

Version 3.7.2 of `eslint-scope` was published without authorization and was found to contain malicious code. This code would read the users `.npmrc` file and send any found authentication tokens to 2 remote servers. Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens

Related

Weakness · CWE (1)

  • CWE-506 Embedded Malicious Code weakness

References