GitHub Advisoryadvisory · Maven
GHSA-j239-4gqg-5j54 Inadequate Encryption Strength
CRITICAL
Official page ↗
- Aliases
- CVE-2017-1000486
- Ecosystem
- Maven
- Packages
- org.primefaces:primefaces
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-326
- Reviewed
- 2021-06-03
Affected packages
• Maven org.primefaces:primefaces: >= 5.0, < 6.0 → fixed in 6.0
Description
Primetek Primefaces 5.x is vulnerable to a weak encryption flaw resulting in remote code execution
Related
Alias · CVE (1)
- CVE-2017-1000486 Primetek Primefaces 5.x is vulnerable to a weak encryption flaw resulting in remote code execution vulnerability
Weakness · CWE (1)
- CWE-326 Inadequate Encryption Strength weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000486 advisory
- https://github.com/primefaces/primefaces/issues/1152 web
- https://cryptosense.com/weak-encryption-flaw-in-primefaces web
- https://www.exploit-db.com/exploits/43733 web
- http://blog.mindedsecurity.com/2016/02/rce-in-oracle-netbeans-opensource.html web