GitHub Advisoryadvisory · Packagist
GHSA-j2fp-9wp5-mg66 Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
MEDIUM
Official page ↗
- Aliases
- CVE-2017-1000442
- Ecosystem
- Packagist
- Packages
- passbolt/passbolt_api
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-17
Affected packages
• Packagist passbolt/passbolt_api: < 1.6.5 → fixed in 1.6.5
Description
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
Related
Alias · CVE (1)
- CVE-2017-1000442 Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000442 advisory
- https://github.com/passbolt/passbolt_api/commit/f5eb93485a90195439e12aa8072f45ceb37b19c3 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/passbolt/passbolt_api/CVE-2017-1000442.yaml web
- https://github.com/passbolt/passbolt_api package
- https://www.passbolt.com/incidents/20170914_xss_on_resource_urls web
- https://www.passbolt.com/release/notes#September web