GitHub Advisoryadvisory · PyPI

GHSA-j2h6-73x8-22c4 Exposure of Sensitive Information to an Unauthorized Actor in ansible

MEDIUM Published 2021-04-20 Modified 2024-09-11 Official page ↗
Aliases
CVE-2020-1746
Ecosystem
PyPI
Packages
ansible
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2021-04-02

Affected packages

• PyPI ansible: >= 2.8.0a1, < 2.8.11 → fixed in 2.8.11 • PyPI ansible: >= 2.9.0a1, < 2.9.7 → fixed in 2.9.7 • PyPI ansible: >= 2.7.0a1, < 2.7.17 → fixed in 2.7.17

Description

A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the `bind_pw` in the parameters field. The highest threat from this vulnerability is data confidentiality.

Related

Alias · CVE (1)

  • CVE-2020-1746 A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References