GitHub Advisoryadvisory · NuGet

GHSA-j378-6mmw-hqfr Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests

HIGH Published 2018-10-16 Modified 2022-10-26 Official page ↗
Aliases
CVE-2018-8409
Ecosystem
NuGet
Packages
Microsoft.AspNetCore.All, Microsoft.AspNetCore.App, System.IO.Pipelines
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2020-06-16

Affected packages

• NuGet Microsoft.AspNetCore.All: >= 2.1.0, < 2.1.4 → fixed in 2.1.4 • NuGet Microsoft.AspNetCore.App: >= 2.1.0, < 2.1.4 → fixed in 2.1.4 • NuGet System.IO.Pipelines: >= 4.5.0, < 4.5.1 → fixed in 4.5.1

Description

A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.

Related

Alias · CVE (1)

  • CVE-2018-8409 A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service."… vulnerability

References