GitHub Advisoryadvisory · NuGet

GHSA-j3g9-6fx5-gjv7 Inadequate Encryption Strength in DotNetNuke

HIGH Published 2019-07-05 Modified 2025-10-22 Official page ↗
Aliases
CVE-2018-18325
Ecosystem
NuGet
Packages
DotNetNuke.Core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:H
Weaknesses
CWE-326
Reviewed
2019-07-05

Affected packages

• NuGet DotNetNuke.Core: < 9.3.0 → fixed in 9.3.0

Description

DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. NOTE: this issue exists because of an incomplete fix for CVE-2018-15811.

Related

Alias · CVE (1)

  • CVE-2018-18325 DNN (aka DotNetNuke) 9.2 through 9.2.2 uses a weak encryption algorithm to protect input parameters. vulnerability

Weakness · CWE (1)

  • CWE-326 Inadequate Encryption Strength weakness

References