GitHub Advisoryadvisory · Packagist

GHSA-j3j5-5m8v-7gvc BuddyPress: Authenticated attackers can access arbitrary private message threads via user_id request parameter

HIGH Published 2026-06-10 Modified 2026-08-12 Official page ↗
Aliases
CVE-2026-53673
Ecosystem
Packagist
Packages
buddypress/buddypress
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-639
Reviewed
2026-08-12

Affected packages

• Packagist buddypress/buddypress: < 14.5.0 → fixed in 14.5.0

Description

BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.

Related

Alias · CVE (1)

  • CVE-2026-53673 BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers… vulnerability

Weakness · CWE (1)

  • CWE-639 Authorization Bypass Through User-Controlled Key weakness

References