GitHub Advisoryadvisory · npm

GHSA-j3mm-wmfm-mwvh Cross-site scripting (XSS) in the CKEditor 5 real-time collaboration package

MEDIUM Published 2025-02-20 Modified 2025-02-20 Official page ↗
Aliases
CVE-2025-25299
Ecosystem
npm
Packages
@ckeditor/ckeditor5-real-time-collaboration, ckeditor5-premium-features
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79, CWE-80
Reviewed
2025-02-20

Affected packages

• npm @ckeditor/ckeditor5-real-time-collaboration: >= 41.3.0, < 44.2.1 → fixed in 44.2.1 • npm ckeditor5-premium-features: >= 42.0.0, < 44.2.1 → fixed in 44.2.1

Description

Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 real-time collaboration package. This vulnerability can lead to unauthorized JavaScript code execution and affects user markers, which represent users' positions within the document. This vulnerability affects only installations with Real-time collaborative editing enabled. Patches The problem has been recognized and patched. The fix will be available in version 44.2.1 (and above). For more information Email us at [email protected] if you have any questions or comments about this advisory.

Related

Alias · CVE (1)

  • CVE-2025-25299 CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. vulnerability

Weakness · CWE (2)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness
  • CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page weakness

References