GitHub Advisoryadvisory · PyPI

GHSA-j3vq-pmp5-r5xj Missing ratelimit on passwrod resets in zenml

MEDIUM Published 2024-11-14 Modified 2024-11-18 Official page ↗
Aliases
CVE-2024-4311
Ecosystem
PyPI
Packages
zenml
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weaknesses
CWE-770
Reviewed
2024-11-14

Affected packages

• PyPI zenml: < 0.57.0rc2 → fixed in 0.57.0rc2

Description

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Related

Alias · CVE (1)

  • CVE-2024-4311 zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References