GitHub Advisoryadvisory · Packagist
GHSA-j3x5-cwfj-pfcw Moodle does not force password changes for autosubscribed users
MEDIUM
Official page ↗
- Aliases
- CVE-2011-4287
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
- Weaknesses
- CWE-263
- Reviewed
- 2025-04-12
Affected packages
• Packagist moodle/moodle: >= 2.0.0, < 2.0.2 → fixed in 2.0.2
Description
admin/uploaduser_form.php in Moodle 2.0.x before 2.0.3 does not force password changes for autosubscribed users, which makes it easier for remote attackers to obtain access by leveraging knowledge of the initial password of a new user.
Related
Alias · CVE (1)
- CVE-2011-4287 admin/uploaduser_form.php in Moodle 2.0.x before 2.0.3 does not force password changes for autosubscribed users, which makes it easier for… vulnerability
Weakness · CWE (1)
- CWE-263 Password Aging with Long Expiration weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2011-4287 advisory
- http://git.moodle.org package
- http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=22a77963439e00441949440f0517135b3a5418da web
- http://git.moodle.org/gw?p=moodle.git;a=commit;h=22a77963439e00441949440f0517135b3a5418da web
- http://moodle.org/mod/forum/discuss.php?d=175588 web
- http://openwall.com/lists/oss-security/2011/11/14/1 web