GitHub Advisoryadvisory · PyPI
GHSA-j4gv-6x9v-v23g OMERO.web uses jquery-form library, which may be vulnerable to XSS attack
LOW
Official page ↗
- Ecosystem
- PyPI
- Packages
- omero-web
- Severity
- Low
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U
- Weaknesses
- CWE-79
- Reviewed
- 2025-11-24
Affected packages
• PyPI omero-web: < 5.29.3 → fixed in 5.29.3
Description
Impact
OMERO.web uses the jquery-form library throughout to handle form submission and response processing. Due to some unpatched potential vulnerabilities in jquery-form, OMERO.web 5.29.2 and earlier may be susceptible to XSS attacks.
Patches
User should upgrade OMERO.web to 5.29.3 or higher.
Workarounds
None.
Resources
https://github.com/jquery-form/form/issues/604
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness