GitHub Advisoryadvisory · RubyGems
GHSA-j4h6-gcj7-7v9v decidim-meetings Cross-site scripting vulnerability in the online or hybrid meeting embeds
MEDIUM
Official page ↗
- Aliases
- CVE-2024-45594
- Ecosystem
- RubyGems
- Packages
- decidim-meetings
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-11-13
Affected packages
• RubyGems decidim-meetings: >= 0.28.0, < 0.28.3 → fixed in 0.28.3
Description
Impact
The meeting embeds feature used in the online or hybrid meetings is subject to potential XSS attack through a malformed URL.
Patches
Not available
Workarounds
Disable the creation of meetings by participants in the meeting component.
References
OWASP ASVS v4.0.3-5.1.3
Credits
This issue was discovered in a security audit organized by mitgestalten Partizipationsbüro against Decidim. The security audit was implemented by the Austrian Institute of Technology.
Related
Alias · CVE (1)
- CVE-2024-45594 Decidim is a participatory democracy framework. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness