GitHub Advisoryadvisory · Packagist
GHSA-j4mx-98hw-6rv6 craftcms/cms vulnerable to cross site scripting in RSS feed widget
MEDIUM
Official page ↗
- Aliases
- CVE-2023-31144
- Ecosystem
- Packagist
- Packages
- craftcms/cms
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-05-05
Affected packages
• Packagist craftcms/cms: >= 3.0.0, < 3.8.4 → fixed in 3.8.4
• Packagist craftcms/cms: >= 4.0.0, < 4.4.4 → fixed in 4.4.4
Description
A malformed title in the feed widget of craftcms/cms can deliver an XSS payload. This has been resolved in this commit.
Related
Alias · CVE (1)
- CVE-2023-31144 Craft CMS is a content management system. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/craftcms/cms/security/advisories/GHSA-j4mx-98hw-6rv6 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-31144 advisory
- https://github.com/craftcms/cms/commit/52bd161614620edbab2d24d078ca9ebca2528442 web
- https://github.com/craftcms/cms/commit/e2f7e7b7d86a0afa54ce855375d13c7760670764 web
- https://github.com/craftcms/cms package