GitHub Advisoryadvisory · Maven

GHSA-j4wf-9gx8-63f8 Jenkins Applitools Eyes Plugin vulnerable to XSS through its Build page

HIGH Published 2025-07-09 Modified 2025-11-05 Official page ↗
Aliases
CVE-2025-53658
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:applitools-eyes
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2025-07-09

Affected packages

• Maven org.jenkins-ci.plugins:applitools-eyes: < 1.16.6 → fixed in 1.16.6

Description

Jenkins Applitools Eyes Plugin 1.16.5 and earlier does not escape the Applitools URL on the build page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Applitools Eyes Plugin 1.16.6 rejects Applitools URLs that contain HTML metacharacters.

Related

Alias · CVE (1)

  • CVE-2025-53658 Jenkins Applitools Eyes Plugin 1.16.5 and earlier does not escape the Applitools URL on the build page, resulting in a stored cross-site… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References