GitHub Advisoryadvisory · PyPI

GHSA-j527-v579-m98h Improper authentication in zenml

LOW Published 2024-06-06 Modified 2025-10-15 Official page ↗
Aliases
CVE-2024-2213
Ecosystem
PyPI
Packages
zenml
Severity
Low
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-287, CWE-620
Reviewed
2024-06-06

Affected packages

• PyPI zenml: < 0.56.3 → fixed in 0.56.3

Description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

Related

Alias · CVE (1)

  • CVE-2024-2213 An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-620 Unverified Password Change weakness

References