GitHub Advisoryadvisory · npm
GHSA-j533-2g8v-pmpg Regular Expression Denial of Service in simple-markdown
HIGH
Official page ↗
- Aliases
- CVE-2019-25102
- Ecosystem
- npm
- Packages
- simple-markdown
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1333
- Reviewed
- 2023-02-14
Affected packages
• npm simple-markdown: < 0.6.1 → fixed in 0.6.1
Description
A vulnerability, which was classified as problematic, was found in simple-markdown 0.6.0. Affected is an unknown function of the file simple-markdown.js. The manipulation with the input <<<<<<<<<<:/:/:/:/:/:/:/:/:/:/ leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.6.1 is able to address this issue. The name of the patch is 015a719bf5cdc561feea05500ecb3274ef609cd2. It is recommended to upgrade the affected component. VDB-220638 is the identifier assigned to this vulnerability.
Related
Alias · CVE (1)
- CVE-2019-25102 A vulnerability, which was classified as problematic, was found in simple-markdown 0.6.0. vulnerability
Weakness · CWE (1)
- CWE-1333 Inefficient Regular Expression Complexity weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-25102 advisory
- https://github.com/ariabuckles/simple-markdown/pull/73 web
- https://github.com/ariabuckles/simple-markdown/commit/015a719bf5cdc561feea05500ecb3274ef609cd2 web
- https://github.com/ariabuckles/simple-markdown package
- https://github.com/ariabuckles/simple-markdown/releases/tag/0.6.1 web
- https://vuldb.com/?ctiid.220638 web
- https://vuldb.com/?id.220638 web