GitHub Advisoryadvisory · PyPI

GHSA-j569-fghw-f9rx Ansible sensitive information disclosure

HIGH Published 2022-05-13 Modified 2024-11-18 Official page ↗
Aliases
CVE-2018-16876
Ecosystem
PyPI
Packages
ansible
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-04-22

Affected packages

• PyPI ansible: < 2.5.14 → fixed in 2.5.14 • PyPI ansible: >= 2.6.0a1, < 2.6.11 → fixed in 2.6.11 • PyPI ansible: >= 2.7.0a1, < 2.7.5 → fixed in 2.7.5

Description

ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in `vvv+` mode with no_log on that can lead to leakage of sensible data.

Related

Alias · CVE (1)

  • CVE-2018-16876 ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References