GitHub Advisoryadvisory · PyPI

GHSA-j57p-g33w-95c5 OpenStack Horizon Cross-site scripting (XSS) vulnerability

LOW Published 2022-05-13 Modified 2023-10-19 Official page ↗
Aliases
CVE-2014-3474
Ecosystem
PyPI
Packages
horizon
Severity
Low
Weaknesses
CWE-79
Reviewed
2023-10-19

Affected packages

• PyPI horizon: < 8.0.0a0 → fixed in 8.0.0a0

Description

Cross-site scripting (XSS) vulnerability in `horizon/static/horizon/js/horizon.instances.js` in the Launch Instance menu in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2 allows remote authenticated users to inject arbitrary web script or HTML via a network name.

Related

Alias · CVE (1)

  • CVE-2014-3474 Cross-site scripting (XSS) vulnerability in horizon/static/horizon/js/horizon.instances.js in the Launch Instance menu in OpenStack… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References