GitHub Advisoryadvisory · Packagist

GHSA-j5jh-hpr4-h332 Symfony Session Fixation Vulnerability

LOW Published 2022-05-14 Modified 2024-02-08 Official page ↗
Aliases
CVE-2015-8124
Ecosystem
Packagist
Packages
symfony/symfony, symfony/security-http, symfony/security
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Weaknesses
CWE-384
Reviewed
2023-08-02

Affected packages

• Packagist symfony/symfony: >= 2.3.0, < 2.3.35 → fixed in 2.3.35 • Packagist symfony/symfony: >= 2.4.0, < 2.6.12 → fixed in 2.6.12 • Packagist symfony/symfony: >= 2.7.0, < 2.7.7 → fixed in 2.7.7 • Packagist symfony/security-http: >= 2.4.0, < 2.6.12 → fixed in 2.6.12 • Packagist symfony/security-http: >= 2.7.0, < 2.7.7 → fixed in 2.7.7 • Packagist symfony/security: >= 2.3.0, < 2.3.35 → fixed in 2.3.35 • Packagist symfony/security: >= 2.4.0, < 2.6.12 → fixed in 2.6.12 • Packagist symfony/security: >= 2.7.0, < 2.7.7 → fixed in 2.7.7

Description

A session fixation vulnerability within the "Remember Me" login feature allows an attacker to impersonate the victim towards the web application if the session id value was previously known to the attacker. This issue has been fixed in Symfony 2.3.35, 2.6.12, and 2.7.7. Note that no fixes are provided for Symfony 2.4 and 2.5 as they are not maintained anymore. Symfony 2.8 and 3.0 haven't been released yet and the fix will be included in their first stable releases.

Related

Alias · CVE (1)

  • CVE-2015-8124 Session fixation vulnerability in the "Remember Me" login feature in Symfony 2.3.x before 2.3.35, 2.6.x before 2.6.12, and 2.7.x before… vulnerability

Weakness · CWE (1)

  • CWE-384 Session Fixation weakness

References