GitHub Advisoryadvisory · Packagist

GHSA-j5jv-w5cw-j9ff Moodle authentication bypass vulnerability

HIGH Published 2026-02-03 Modified 2026-02-03 Official page ↗
Aliases
CVE-2025-67848
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-280
Reviewed
2026-02-03

Affected packages

• Packagist moodle/moodle: < 4.1.22 → fixed in 4.1.22 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.12 → fixed in 4.4.12 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.8 → fixed in 4.5.8 • Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.4 → fixed in 5.0.4 • Packagist moodle/moodle: >= 5.1.0-beta, < 5.1.1 → fixed in 5.1.1

Description

A flaw was found in Moodle. This authentication bypass vulnerability allows suspended users to authenticate through the Learning Tools Interoperability (LTI) Provider. The issue arises from the LTI authentication handlers failing to enforce the user's suspension status, enabling unauthorized access to the system. This can lead to information disclosure or other unauthorized actions by users who should be restricted.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-280 Improper Handling of Insufficient Permissions or Privileges weakness

References