GitHub Advisoryadvisory · Go
GHSA-j639-m367-75cf Mattermost Incorrect Authorization vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-24839
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-04-16
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 10.5.0, < 10.5.2 → fixed in 10.5.2
• Go github.com/mattermost/mattermost/server/v8: >= 10.4.0, < 10.4.4 → fixed in 10.4.4
• Go github.com/mattermost/mattermost/server/v8: >= 9.11.0, < 9.11.10 → fixed in 9.11.10
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250314142426-c049748b8863 → fixed in 8.0.0-20250314142426-c049748b8863
Description
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.
Related
Alias · CVE (1)
- CVE-2025-24839 Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness