GitHub Advisoryadvisory · Maven
GHSA-j63j-7r7r-5v4j WSO2 products vulnerable to privilege escalation due to business logic flaw in SOAP admin services
MEDIUM
Official page ↗
- Aliases
- CVE-2024-7096
- Ecosystem
- Maven
- Packages
- org.wso2.am:am-parent, org.wso2.is:identity-server-parent
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2025-06-04
Affected packages
• Maven org.wso2.am:am-parent: >= 2.0.0, < 4.4.0 → fixed in 4.4.0
• Maven org.wso2.is:identity-server-parent: >= 5.2.0, < 7.1.0 → fixed in 7.1.0
Description
A privilege escalation vulnerability exists in multiple WSO2 products due to a business logic flaw in SOAP admin services. A malicious actor can create a new user with elevated permissions only when all of the following conditions are met:
• SOAP admin services are accessible to the attacker.
• The deployment includes an internally used attribute that is not part of the default WSO2 product configuration.
• At least one custom role exists with non-default permissions.
• The attacker has knowledge of the custom role and the internal attribute used in the deployment.
Exploiting this vulnerability allows malicious actors to assign higher privileges to self-registered users, bypassing intended access control mechanisms.
Related
Alias · CVE (1)
- CVE-2024-7096 A privilege escalation vulnerability exists in multiple WSO2 products due to a business logic flaw in SOAP admin services. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-7096 advisory
- https://github.com/wso2/docs-security/blob/cfd53689909eef62fc5427e193e35e7df8ab1ef8/en/docs/security-announcements/security-advisories/2024/WSO2-2024-3573.md web
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2024/WSO2-2024-3573 web