GitHub Advisoryadvisory · Packagist
GHSA-j63v-wcf9-c9hm Magento 2 Community Edition RCE Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-8119
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2023-07-18
Affected packages
• Packagist magento/community-edition: >= 2.1.0, < 2.1.19 → fixed in 2.1.19
• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3.0, < 2.3.3 → fixed in 2.3.3
Description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated admin user with import product privileges can delete files through bulk product import and inject code into XSLT file. The combination of these manipulations can lead to remote code execution.
Related
Alias · CVE (1)
- CVE-2019-8119 A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8119 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8119.yaml web
- https://github.com/magento/magento2 package
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update web
- https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update web