GitHub Advisoryadvisory · Maven
GHSA-j664-qhh4-hpf8 Cross-site Scripting vulnerability in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2023-27898
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2023-03-17
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 2.376, < 2.394 → fixed in 2.394
• Maven org.jenkins-ci.main:jenkins-core: < 2.375.4 → fixed in 2.375.4
Description
Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.
Related
Alias · CVE (1)
- CVE-2023-27898 Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness