GitHub Advisoryadvisory · RubyGems
GHSA-j6gc-792m-qgm2 ReDoS based DoS vulnerability in Active Support's underscore
LOW
Official page ↗
- Aliases
- CVE-2023-22796
- Ecosystem
- RubyGems
- Packages
- activesupport
- Severity
- Low
- Weaknesses
- CWE-1333
- Reviewed
- 2023-01-18
Affected packages
• RubyGems activesupport: < 6.1.7.1 → fixed in 6.1.7.1
• RubyGems activesupport: >= 7.0.0, < 7.0.4.1 → fixed in 7.0.4.1
Description
There is a possible regular expression based DoS vulnerability in Active Support. This vulnerability has been assigned the CVE identifier CVE-2023-22796.
Versions Affected: All Not affected: None Fixed Versions: 5.2.8.15 (Rails LTS, which is a paid service and not part of the rubygem), 6.1.7.1, 7.0.4.1
Impact
A specially crafted string passed to the underscore method can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability.
This affects String#underscore, ActiveSupport::Inflector.underscore, String#titleize, and any other methods using these.
All users running an affected release should either upgrade or use one of the workarounds immediately.
Releases
The FIXED releases are available at the normal locations.
Workarounds
There are no feasible workarounds for this issue.
Users on Ruby 3.2.0 or greater may be able to reduce the impact by configuring Regexp.timeout.
Patches
To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.
6-1-Avoid-regex-backtracking-in-Inflector.underscore.patch - Patch for 6.1 series
7-0-Avoid-regex-backtracking-in-Inflector.underscore.patch - Patch for 7.0 series
Please note that only the 7.0.Z and 6.1.Z series are supported at present, and 6.0.Z for severe vulnerabilities. Users of earlier unsupported releases are advised to upgrade as soon as possible as we cannot guarantee the continued availability of security fixes for unsupported releases.
Related
Alias · CVE (1)
- CVE-2023-22796 A regular expression based DoS vulnerability in Active Support <6.1.7.1 and <7.0.4.1. vulnerability
Weakness · CWE (1)
- CWE-1333 Inefficient Regular Expression Complexity weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-22796 advisory
- https://github.com/rails/rails/commit/2164d4f6a1bde74b911fe9ba3c8df1b5bf345bf8 web
- https://github.com/rails/rails/commit/a7cda7e6aa5334ab41b1f4b0f671be931be946ef web
- https://discuss.rubyonrails.org/t/cve-2023-22796-possible-redos-based-dos-vulnerability-in-active-supports-underscore/82116 web
- https://github.com/rails/rails package
- https://github.com/rails/rails/releases/tag/v6.1.7.1 web
- https://github.com/rails/rails/releases/tag/v7.0.4.1 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activesupport/CVE-2023-22796.yml web
- https://rubyonrails.org/2023/1/17/Rails-Versions-6-0-6-1-6-1-7-1-7-0-4-1-have-been-released web