GitHub Advisoryadvisory · Maven

GHSA-j77q-2qqg-6989 Apache Struts vulnerable to remote arbitrary command execution due to improper input validation

CRITICAL Published 2018-10-18 Modified 2025-10-22 Official page ↗
Aliases
CVE-2017-5638
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H/E:H
Weaknesses
CWE-20, CWE-755
Reviewed
2020-06-16

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.3.0, < 2.3.32 → fixed in 2.3.32 • Maven org.apache.struts:struts2-core: >= 2.5.0, < 2.5.10.1 → fixed in 2.5.10.1

Description

Apache Struts versions prior to 2.3.32 and 2.5.10.1 contain incorrect exception handling and error-message generation during file-upload attempts using the Jakarta Multipart parser, which allows remote attackers to execute arbitrary commands via a crafted Content-Type, Content-Disposition, or Content-Length HTTP header, as exploited in the wild in March 2017 with a Content-Type header containing a #cmd= string.

Related

Alias · CVE (1)

  • CVE-2017-5638 The Jakarta Multipart parser in Apache Struts 2 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1 has incorrect exception handling and… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-755 Improper Handling of Exceptional Conditions weakness

References