GitHub Advisoryadvisory · Maven

GHSA-j7p2-87q3-44w7 XWiki does not require right warnings for notification displayer objects

MEDIUM Published 2025-06-13 Modified 2025-06-13 Official page ↗
Aliases
CVE-2025-49587
Ecosystem
Maven
Packages
org.xwiki.platform:xwiki-platform-notifications-notifiers-default
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
Weaknesses
CWE-357
Reviewed
2025-06-13

Affected packages

• Maven org.xwiki.platform:xwiki-platform-notifications-notifiers-default: >= 15.9-rc-1, < 15.10.16 → fixed in 15.10.16 • Maven org.xwiki.platform:xwiki-platform-notifications-notifiers-default: >= 16.0.0-rc-1, < 16.4.7 → fixed in 16.4.7 • Maven org.xwiki.platform:xwiki-platform-notifications-notifiers-default: >= 16.5.0-rc-1, < 16.10.2 → fixed in 16.10.2

Description

Impact When a user without script right creates a document with an `XWiki.Notifications.Code.NotificationDisplayerClass` object, and later an admin edits and saves that document, the possibly malicious content of that object is output as raw HTML, allowing XSS attacks. While the notification displayer executes Velocity, the existing generic analyzer already warns admins before editing Velocity code. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. Patches This vulnerability has been patched in XWiki 15.10.16, 16.4.7, and 16.10.2 by adding a required rights analyzer that warns the admin before editing about the possibly malicious code. Workarounds We're not aware of any real workarounds apart from just being careful with editing documents previously edited by untrusted users as a user with script, admin or programming right.

Related

Alias · CVE (1)

  • CVE-2025-49587 XWiki is an open-source wiki software platform. vulnerability

Weakness · CWE (1)

  • CWE-357 Insufficient UI Warning of Dangerous Operations weakness

References