GitHub Advisoryadvisory · Maven
GHSA-j7q2-c6r4-x2jw Stored XSS vulnerability in Jenkins Git Parameter Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2238
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.tools:git-parameter
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-21
Affected packages
• Maven org.jenkins-ci.tools:git-parameter: < 0.9.13 → fixed in 0.9.13
Description
Jenkins Git Parameter Plugin 0.9.12 and earlier does not escape the repository field on the 'Build with Parameters' page, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Git Parameter Plugin 0.9.13 escapes the repository field on the 'Build with Parameters' page.
Related
Alias · CVE (1)
- CVE-2020-2238 Jenkins Git Parameter Plugin 0.9.12 and earlier does not escape the repository field on the 'Build with Parameters' page, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2238 advisory
- https://github.com/jenkinsci/git-parameter-plugin/commit/7014c4dd030ee4226b4795137050743a84d67cb0 web
- https://github.com/jenkinsci/git-parameter-plugin package
- https://jenkins.io/security/advisory/2020-09-01/#SECURITY-1884 web
- http://www.openwall.com/lists/oss-security/2020/09/01/3 web