GitHub Advisoryadvisory · Packagist

GHSA-j82x-fh8h-326g Yii2 FileAPI Widget vulnerable to Cross-site Scripting

MEDIUM Published 2022-12-31 Modified 2023-12-29 Official page ↗
Aliases
CVE-2017-20158
Ecosystem
Packagist
Packages
vova07/yii2-fileapi-widget
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-01-09

Affected packages

• Packagist vova07/yii2-fileapi-widget: < 0.1.9 → fixed in 0.1.9

Description

A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 can address this issue. The name of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Related

Alias · CVE (1)

  • CVE-2017-20158 ** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References