GitHub Advisoryadvisory · npm
GHSA-j8j5-7r4h-vj2g DbGate has cross site scripting via the SVG Icon String Handler component
LOW
Official page ↗
- Aliases
- CVE-2026-6216
- Ecosystem
- npm
- Packages
- dbgate-web
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-04-14
Affected packages
• npm dbgate-web: < 7.1.5 → fixed in 7.1.5
Description
A security vulnerability has been detected in DbGate up to 7.1.4. This affects an unknown function of the file packages/web/src/icons/FontIcon.svelte of the component SVG Icon String Handler. Such manipulation of the argument applicationIcon leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 7.1.5 mitigates this issue. It is advisable to upgrade the affected component.
Related
Alias · CVE (1)
- CVE-2026-6216 A security vulnerability has been detected in DbGate up to 7.1.4. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness