GitHub Advisoryadvisory · PyPI
GHSA-j8j8-348v-wfm3 Python-saml allows manipulation of SAML data without invalidation of cryptographic signature
HIGH
Official page ↗
- Aliases
- CVE-2017-11427
- Ecosystem
- PyPI
- Packages
- python-saml
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2020-06-16
Affected packages
• PyPI python-saml: < 2.4.0 → fixed in 2.4.0
Description
OneLogin PythonSAML 2.3.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Related
Alias · CVE (1)
- CVE-2017-11427 OneLogin PythonSAML 2.3.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that… vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-11427 advisory
- https://github.com/SAML-Toolkits/python-saml/commit/fad881b4432febea69d70691dfed51c93f0de10f web
- https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations web
- https://github.com/SAML-Toolkits/python-saml package
- https://github.com/advisories/GHSA-j8j8-348v-wfm3 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/python-saml/PYSEC-2019-198.yaml web
- https://www.kb.cert.org/vuls/id/475445 web