GitHub Advisoryadvisory · Maven

GHSA-j8mx-j73w-9mxw Vaadin Build Plugins is Affected by a Possible Information Disclosure Vulnerability

LOW Published 2026-05-19 Modified 2026-06-04 Official page ↗
Aliases
CVE-2026-7860
Ecosystem
Maven
Packages
com.vaadin:flow-plugins, com.vaadin:flow-maven-plugin, com.vaadin:flow-gradle-plugin
Severity
Low
CVSS vector
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/S:N/AU:N/R:A/V:C/RE:L/U:Green
Weaknesses
CWE-209
Reviewed
2026-06-04

Affected packages

• Maven com.vaadin:flow-plugins: >= 23.0.0, < 23.6.11 → fixed in 23.6.11 • Maven com.vaadin:flow-plugins: >= 24.0.0, < 24.9.18 → fixed in 24.9.18 • Maven com.vaadin:flow-plugins: >= 24.10.0, < 24.10.4 → fixed in 24.10.4 • Maven com.vaadin:flow-plugins: >= 25.0.0, < 25.0.12 → fixed in 25.0.12 • Maven com.vaadin:flow-plugins: >= 25.1.0, < 25.1.5 → fixed in 25.1.5 • Maven com.vaadin:flow-maven-plugin: >= 23.0.0, < 23.6.11 → fixed in 23.6.11 • Maven com.vaadin:flow-maven-plugin: >= 24.0.0, < 24.9.18 → fixed in 24.9.18 • Maven com.vaadin:flow-maven-plugin: >= 24.10.0, < 24.10.4 → fixed in 24.10.4 • Maven com.vaadin:flow-maven-plugin: >= 25.0.0, < 25.0.12 → fixed in 25.0.12 • Maven com.vaadin:flow-maven-plugin: >= 25.1.0, < 25.1.5 → fixed in 25.1.5 • Maven com.vaadin:flow-gradle-plugin: >= 24.0.0, < 24.9.18 → fixed in 24.9.18 • Maven com.vaadin:flow-gradle-plugin: >= 24.10.0, < 24.10.4 → fixed in 24.10.4 • Maven com.vaadin:flow-gradle-plugin: >= 25.0.0, < 25.0.12 → fixed in 25.0.12 • Maven com.vaadin:flow-gradle-plugin: >= 25.1.0, < 25.1.5 → fixed in 25.1.5

Description

A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: | Product version | Mitigation | |---|---| | `Vaadin 23.0.0 - 23.6.10` | `Upgrade to 23.6.11` | | `Vaadin 24.0.0 - 24.9.17` | `Upgrade to 24.9.18` | | `Vaadin 24.10.0 - 24.10.3` | `Upgrade to 24.10.4` | | `Vaadin 25.0.0 - 25.0.11` | `Upgrade to 25.0.12` | | `Vaadin 25.1.0 - 25.1.4` | `Upgrade to 25.1.5 or newer` | Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version. | Maven coordinates | Vulnerable version | Fixed version | |---|---|---| | `com.vaadin:flow-plugin-base` | `23.0.0 - 23.6.10` | `≥ 23.6.11` | | `com.vaadin:flow-plugin-base` | `24.0.0 - 24.9.17` | `≥ 24.9.18` | | `com.vaadin:flow-plugin-base` | `24.0.0 - 24.10.3` | `≥ 24.10.4` | | `com.vaadin:flow-plugin-base` | `25.0.0 - 25.0.11` | `≥ 25.0.12` | | `com.vaadin:flow-plugin-base` | `25.1.0 - 25.1.4` | `≥ 25.1.5` | | `com.vaadin:flow-maven-plugin` | `23.0.0 - 23.6.10` | `≥ 23.6.11` | | `com.vaadin:flow-maven-plugin` | `24.0.0 - 24.9.17` | `≥ 24.9.18` | | `com.vaadin:flow-maven-plugin` | `24.0.0 - 24.10.3` | `≥ 24.10.4` | | `com.vaadin:flow-maven-plugin` | `25.0.0 - 25.0.11` | `≥ 25.0.12` | | `com.vaadin:flow-maven-plugin` | `25.1.0 - 25.1.4` | `≥ 25.1.5` | | `com.vaadin:flow-gradle-plugin` | `24.0.0 - 24.9.17` | `≥ 24.9.18` | | `com.vaadin:flow-gradle-plugin` | `24.0.0 - 24.10.3` | `≥ 24.10.4` | | `com.vaadin:flow-gradle-plugin` | `25.0.0 - 25.0.11` | `≥ 25.0.12` | | `com.vaadin:flow-gradle-plugin` | `25.1.0 - 25.1.4` | `≥ 25.1.5` |

Related

Alias · CVE (1)

  • CVE-2026-7860 A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of… vulnerability

Weakness · CWE (1)

  • CWE-209 Generation of Error Message Containing Sensitive Information weakness

References