GitHub Advisoryadvisory · Packagist

GHSA-j8p3-8m69-2hqq CakePHP allows remote attackers to spoof their IP

HIGH Published 2022-05-14 Modified 2023-01-14 Official page ↗
Aliases
CVE-2016-4793
Ecosystem
Packagist
Packages
cakephp/cakephp
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-20
Reviewed
2023-01-14

Affected packages

• Packagist cakephp/cakephp: >= 1.2.0, < 2.6.13 → fixed in 2.6.13 • Packagist cakephp/cakephp: >= 2.7.0-rc1, < 2.7.11 → fixed in 2.7.11 • Packagist cakephp/cakephp: >= 2.8.0-rc1, < 2.8.2 → fixed in 2.8.2 • Packagist cakephp/cakephp: >= 3.0.0-rc1, < 3.0.17 → fixed in 3.0.17 • Packagist cakephp/cakephp: >= 3.1.0-beta1, < 3.1.12 → fixed in 3.1.12 • Packagist cakephp/cakephp: >= 3.2.0-rc1, < 3.2.5 → fixed in 3.2.5

Description

The `clientIp` function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the `CLIENT-IP HTTP` header.

Related

Alias · CVE (1)

  • CVE-2016-4793 The clientIp function in CakePHP 3.2.4 and earlier allows remote attackers to spoof their IP via the CLIENT-IP HTTP header. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References