GitHub Advisoryadvisory · Maven
GHSA-j8qv-mj4r-6fw4 Improper Input Validation in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2018-1999001
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-06-28
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.121.2 → fixed in 2.121.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.122, < 2.132 → fixed in 2.132
Description
A unauthorized modification of configuration vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in User.java that allows attackers to provide crafted login credentials that cause Jenkins to move the config.xml file from the Jenkins home directory. If Jenkins is started without this file present, it will revert to the legacy defaults of granting administrator access to anonymous users.
Related
Alias · CVE (1)
- CVE-2018-1999001 A unauthorized modification of configuration vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in User.java that… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999001 advisory
- https://github.com/jenkinsci/jenkins/commit/5f4d014b3b7f89e206c6c8509540ed559f604959 web
- https://github.com/jenkinsci/jenkins package
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-897 web
- https://www.oracle.com/security-alerts/cpuapr2022.html web