GitHub Advisoryadvisory · Packagist
GHSA-j934-vjh5-vf9r Magneto contains stored XSS vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2025-47110
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2025-06-24
Affected packages
• Packagist magento/community-edition: >= 2.4.8-beta1, < 2.4.8-p1 → fixed in 2.4.8-p1
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p6 → fixed in 2.4.7-p6
• Packagist magento/community-edition: < 2.4.5-p13 → fixed in 2.4.5-p13
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.8 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p11 → fixed in 2.4.6-p11
• Packagist magento/community-edition: 2.4.6 (no fix yet)
Description
Magento versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Related
Alias · CVE (1)
- CVE-2025-47110 Adobe Commerce versions 2.4.8, 2.4.7-p5, 2.4.6-p10, 2.4.5-p12, 2.4.4-p13 and earlier are affected by a stored Cross-Site Scripting (XSS)… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness