GitHub Advisoryadvisory · RubyGems

GHSA-j96r-xvjq-r9pg activesupport vulnerable to Denial of Service via large XML document depth

MEDIUM Published 2017-10-24 Modified 2025-03-31 Official page ↗
Aliases
CVE-2015-3227
Ecosystem
RubyGems
Packages
activesupport
Severity
Moderate
Reviewed
2020-06-16

Affected packages

• RubyGems activesupport: >= 4.0.0.beta1, < 4.1.11 → fixed in 4.1.11 • RubyGems activesupport: >= 4.2.0.beta1, < 4.2.2 → fixed in 4.2.2 • RubyGems activesupport: < 3.2.22 → fixed in 3.2.22

Description

The (1) `jdom.rb` and (2) `rexml.rb` components in Active Support in Ruby on Rails before 3.2.22, 4.1.x before 4.1.11, and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.

Related

Alias · CVE (1)

  • CVE-2015-3227 The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is… vulnerability

References