GitHub Advisoryadvisory · Packagist
GHSA-j99g-qjvx-995g Contao Does Not Expire Tokens Correctly
CRITICAL
Official page ↗
- Aliases
- CVE-2019-10643
- Ecosystem
- Packagist
- Packages
- contao/contao, contao/core-bundle
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287, CWE-324
- Reviewed
- 2024-04-25
Affected packages
• Packagist contao/contao: >= 4.7.0, < 4.7.3 → fixed in 4.7.3
• Packagist contao/core-bundle: >= 4.7.0, < 4.7.3 → fixed in 4.7.3
Description
Security researcher Ali Razzaq has discovered that confirming an opt-in token does not invalidate previous opt-in tokens in Contao 4.7.
Related
Alias · CVE (1)
- CVE-2019-10643 Contao 4.7 allows Use of a Key Past its Expiration Date. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10643 advisory
- https://github.com/contao/contao/commit/70348cc812b110831ad66a4f9857883f75649b88 web
- https://contao.org/en/news.html web
- https://contao.org/en/news/security-vulnerability-cve-2019-10643.html web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2019-10643.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2019-10643.yaml web