GitHub Advisoryadvisory · Packagist
GHSA-j9f9-8j39-4g97 CodeIgniter HTTP Header Injection
HIGH
Official page ↗
- Aliases
- CVE-2017-1000247
- Ecosystem
- Packagist
- Packages
- codeigniter4/framework
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-04-24
Affected packages
• Packagist codeigniter4/framework: >= 3.1.3, < 3.1.4 → fixed in 3.1.4
Description
British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set_status_header() common function under Apache resulting in HTTP Header Injection flaws.
Related
Alias · CVE (1)
- CVE-2017-1000247 British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set_status_header() common… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness