GitHub Advisoryadvisory · Maven

GHSA-jc7p-5r39-9477 Improper Input Validation in Apache Tomcat

HIGH Published 2022-05-13 Modified 2024-02-22 Official page ↗
Aliases
CVE-2016-6816
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat-coyote
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2022-07-06

Affected packages

• Maven org.apache.tomcat:tomcat-coyote: >= 9.0.0.M1, < 9.0.0.M12 → fixed in 9.0.0.M12 • Maven org.apache.tomcat:tomcat-coyote: >= 8.5.0, < 8.5.8 → fixed in 8.5.8 • Maven org.apache.tomcat:tomcat-coyote: >= 8.0.0RC1, < 8.0.39 → fixed in 8.0.39 • Maven org.apache.tomcat:tomcat-coyote: >= 7.0.0, < 7.0.73 → fixed in 7.0.73 • Maven org.apache.tomcat:tomcat-coyote: >= 6.0.0, < 6.0.48 → fixed in 6.0.48

Description

The code in Apache Tomcat 9.0.0.M1 to 9.0.0.M11, 8.5.0 to 8.5.6, 8.0.0.RC1 to 8.0.38, 7.0.0 to 7.0.72, and 6.0.0 to 6.0.47 that parsed the HTTP request line permitted invalid characters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack and/or obtain sensitive information from requests other then their own.

Related

Alias · CVE (1)

  • CVE-2016-6816 The code in Apache Tomcat 9.0.0.M1 to 9.0.0.M11, 8.5.0 to 8.5.6, 8.0.0.RC1 to 8.0.38, 7.0.0 to 7.0.72, and 6.0.0 to 6.0.47 that parsed the… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References