GitHub Advisoryadvisory · PyPI
GHSA-jccx-m9v4-9hwh LoLLMS Code Injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2024-6982
- Ecosystem
- PyPI
- Packages
- lollms
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2025-03-21
Affected packages
• PyPI lollms: < 11.0.0 → fixed in 11.0.0
Description
A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. The vulnerability arises from the use of Python's `eval()` function to evaluate mathematical expressions within a Python sandbox that disables `__builtins__` and only allows functions from the `math` module. This sandbox can be bypassed by loading the `os` module using the `_frozen_importlib.BuiltinImporter` class, allowing an attacker to execute arbitrary commands on the server. The issue is fixed in version 9.10.
Related
Alias · CVE (1)
- CVE-2024-6982 A remote code execution vulnerability exists in the Calculate function of parisneo/lollms version 9.8. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness