GitHub Advisoryadvisory · npm
GHSA-jcpv-g9rr-qxrc Regular Expression Denial of Service in hawk
HIGH
Official page ↗
- Aliases
- CVE-2016-2515
- Ecosystem
- npm
- Packages
- hawk
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1333
- Reviewed
- 2020-06-16
Affected packages
• npm hawk: >= 4.0.0, < 4.1.1 → fixed in 4.1.1
• npm hawk: < 3.1.3 → fixed in 3.1.3
Description
Versions of `hawk` prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
Related
Alias · CVE (1)
- CVE-2016-2515 Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long… vulnerability
Weakness · CWE (1)
- CWE-1333 Inefficient Regular Expression Complexity weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-2515 advisory
- https://github.com/hueniverse/hawk/issues/168 web
- https://github.com/hueniverse/hawk/commit/0833f99ba64558525995a7e21d4093da1f3e15fa web
- https://bugzilla.redhat.com/show_bug.cgi?id=1309721 web
- https://github.com/advisories/GHSA-jcpv-g9rr-qxrc advisory
- https://github.com/hueniverse/hawk package
- https://www.npmjs.com/advisories/77 web
- http://www.openwall.com/lists/oss-security/2016/02/20/1 web
- http://www.openwall.com/lists/oss-security/2016/02/20/2 web