GitHub Advisoryadvisory · PyPI
GHSA-jfq2-rj7f-9gvf Null pointer dereference in TensorFlow leads to exploitation
HIGH
Official page ↗
- Aliases
- CVE-2018-7576
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-476
- Reviewed
- 2019-04-24
Affected packages
• PyPI tensorflow: >= 1.0.0, < 1.6.0 → fixed in 1.6.0
• PyPI tensorflow-gpu: >= 1.0.0, < 1.6.0 → fixed in 1.6.0
Description
Google TensorFlow 1.0.0 through 1.5.1 is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.
Related
Alias · CVE (1)
- CVE-2018-7576 Google TensorFlow 1.6.x and earlier is affected by: Null Pointer Dereference. vulnerability
Weakness · CWE (1)
- CWE-476 NULL Pointer Dereference weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-7576 advisory
- https://github.com/tensorflow/tensorflow/commit/c48431588e7cf8aff61d4c299231e3e925144df8 web
- https://github.com/advisories/GHSA-jfq2-rj7f-9gvf advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-224.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-231.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-206.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-002.md web