GitHub Advisoryadvisory · Maven

GHSA-jg2x-r643-w2ch Jetty Uses Predictable Session Identifiers

MEDIUM Published 2022-05-01 Modified 2024-02-12 Official page ↗
Aliases
CVE-2006-6969
Ecosystem
Maven
Packages
org.eclipse.jetty:jetty-server
Severity
Moderate
Weaknesses
CWE-330
Reviewed
2024-02-12

Affected packages

• Maven org.eclipse.jetty:jetty-server: < 4.2.27 → fixed in 4.2.27 • Maven org.eclipse.jetty:jetty-server: >= 5.1.0, < 5.1.12 → fixed in 5.1.12 • Maven org.eclipse.jetty:jetty-server: >= 6.0.0, < 6.0.2 → fixed in 6.0.2 • Maven org.eclipse.jetty:jetty-server: >= 6.1.0pre1, < 6.1.0pre3 → fixed in 6.1.0pre3

Description

Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util.random, which makes it easier for remote attackers to guess a session identifier through brute force attacks, bypass authentication requirements, and possibly conduct cross-site request forgery attacks.

Related

Alias · CVE (1)

  • CVE-2006-6969 Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using… vulnerability

Weakness · CWE (1)

  • CWE-330 Use of Insufficiently Random Values weakness

References